WordPress 3.3.1 Security and Maintenance Release

WordPress 3.3.1 just released last night.

This maintenance release fixes 15 issues with WordPress 3.3. It also fixes a cross-site scripting vulnerability that affected version 3.3.

Link to WordPress 3.3.1: http://wordpress.org/news/2012/01/wordpress-3-3-1/

How to keep WordPress secure

Matt Mullenweg talks about the need to keep up-to-date with upgrades to guard against security threats:

http://wordpress.org/development/2009/09/keep-wordpress-secure/

Matt discusses a new worm which exploits a vulnerability in older versions of WordPress. The attack creates an admin user and executes code through the “permalinks” functions. The current version of WordPress, 2.8.4, is not vulnerable to this attack.

Keeping updates current is one of the best ways to guard against hacks. If you haven’t upgraded yet, don’t put it off any longer.